summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f25a3fa..d6c1942 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,10 @@ AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign subdir-objects])
AM_SILENT_RULES([yes])
+# We need POSIX functions
+AC_DEFINE([_POSIX_C_SOURCE], [200809L], [Enable POSIX.1-2008 support])
+AC_DEFINE([_XOPEN_SOURCE], [700], [Enable X/OPEN system interfaces])
+
# Checks for programs.
AC_PROG_CC
AC_PROG_CC_STDC