summaryrefslogtreecommitdiffstats
path: root/mingw-w64-gtk3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mingw-w64-gtk3/PKGBUILD')
-rw-r--r--mingw-w64-gtk3/PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/mingw-w64-gtk3/PKGBUILD b/mingw-w64-gtk3/PKGBUILD
index 68133b6..0a71f99 100644
--- a/mingw-w64-gtk3/PKGBUILD
+++ b/mingw-w64-gtk3/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: lantw44 at gmail dot com
pkgname=mingw-w64-gtk3
-pkgver=3.8.4
-pkgrel=2
+pkgver=3.8.5
+pkgrel=1
pkgdesc="GTK+ is a multi-platform toolkit (v3) (mingw-w64)"
arch=(any)
url="http://www.gtk.org"
@@ -26,7 +26,7 @@ source=(
# The second source file is downloaded from GNOME. This file exists in the git repository but not in the tarball. Building of demos will fail without this file.
# The third source file is downloaded from Fedora Project
-md5sums=('2b232d76c01ceb626948bcbe70b05269'
+md5sums=('f5583d1ca338336103ab40b233c6d3ff'
'523aea0be651baaba128c133751a0f01'
'4038939df90f80ea6923d67afff28e03')
@@ -36,21 +36,15 @@ build() {
cd "${srcdir}/gtk+-${pkgver}"
patch -Np0 < '../gtk-dont-define-initguid.patch'
for _arch in ${_architectures}; do
+ unset LDFLAGS
export CFLAGS="-O2 -mms-bitfields"
export CXXFLAGS="${CFLAGS}"
- unset LDFLAGS
- export PKG_CONFIG_FOR_BUILD="${_arch}-pkg-config"
+ export PKG_CONFIG="${_arch}-pkg-config"
+ export PKG_CONFIG_FOR_BUILD="pkg-config"
mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
- msg "Copying files"
- cp -r "${srcdir}/gtk+-${pkgver}/"* \
- "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
cp '../brick.png?h=gtk-3-8&id=231d6c209f47edac828f52a7316980129c370eb1' \
"${srcdir}/gtk+-${pkgver}/demos/gtk-demo/brick.png"
cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
- if [ $_arch = "x86_64-w64-mingw32" ]; then
- rm "gtk/gtk.def"
- fi
- msg "Starting configure and make"
${srcdir}/gtk+-${pkgver}/configure \
--prefix=/usr/${_arch} \
--build=$CHOST \