summaryrefslogtreecommitdiffstats
path: root/mingw-w64-gdk-pixbuf2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mingw-w64-gdk-pixbuf2/PKGBUILD')
-rw-r--r--mingw-w64-gdk-pixbuf2/PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/mingw-w64-gdk-pixbuf2/PKGBUILD b/mingw-w64-gdk-pixbuf2/PKGBUILD
index f44e63a..fab74aa 100644
--- a/mingw-w64-gdk-pixbuf2/PKGBUILD
+++ b/mingw-w64-gdk-pixbuf2/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-gdk-pixbuf2
-pkgver=2.31.1
+pkgver=2.31.2
pkgrel=1
pkgdesc='An image loading library (mingw-w64)'
arch=(any)
@@ -17,13 +17,21 @@ depends=(
'mingw-w64-libjpeg-turbo'
'mingw-w64-libtiff')
options=(!strip !buildflags staticlibs)
-source=("http://download.gnome.org/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz")
-sha256sums=('25a75e3c61dac11e6ff6416ad846951ccafac6486b1c6a1bfb0b213b99db52cd')
+source=(
+ "http://download.gnome.org/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz"
+ "bug-739441-build-Do-not-include-removed-file-gdk-pixbuf-i18n.h.patch"
+ "bug-745402-win32-include-gi18n-lib.h-appropriately.patch")
+sha256sums=('9e467ed09894c802499fb2399cd9a89ed21c81700ce8f27f970a833efb1e47aa'
+ '05d755b2bc55a7dadc26321bfe67b6a383bc931a6127d90f5dd5d3915c3bd30e'
+ '7745276e58843e1be15d1eab49df1c4632e713f3a2fe4b0254c3b0da7370a81b')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/gdk-pixbuf-${pkgver}"
+ patch -Np1 < "../${source[1]}"
+ patch -Np1 < "../${source[2]}"
+ autoreconf -i
for _arch in ${_architectures}; do
unset LDFLAGS
mkdir -p "build-${_arch}"