summaryrefslogtreecommitdiffstats
path: root/yaehmop/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2013-06-03 20:15:33 +0800
committerTing-Wei Lan <lantw44@gmail.com>2013-06-03 20:15:33 +0800
commit21c0ae55d39935e0b8e890985de4aaa52b32f380 (patch)
tree38ca2c2a972f1290c0b2180aaa8e8a9be3dab70a /yaehmop/PKGBUILD
parentbf1e8f64a686cfde4fff0f620106a37e91bbc277 (diff)
downloadAUR4-PKGBUILD-21c0ae55d39935e0b8e890985de4aaa52b32f380.tar
AUR4-PKGBUILD-21c0ae55d39935e0b8e890985de4aaa52b32f380.tar.gz
AUR4-PKGBUILD-21c0ae55d39935e0b8e890985de4aaa52b32f380.tar.bz2
AUR4-PKGBUILD-21c0ae55d39935e0b8e890985de4aaa52b32f380.tar.lz
AUR4-PKGBUILD-21c0ae55d39935e0b8e890985de4aaa52b32f380.tar.xz
AUR4-PKGBUILD-21c0ae55d39935e0b8e890985de4aaa52b32f380.tar.zst
AUR4-PKGBUILD-21c0ae55d39935e0b8e890985de4aaa52b32f380.zip
yaehmop: 3.1.0b2 (initial commit)
Diffstat (limited to 'yaehmop/PKGBUILD')
-rw-r--r--yaehmop/PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/yaehmop/PKGBUILD b/yaehmop/PKGBUILD
new file mode 100644
index 0000000..8d467cc
--- /dev/null
+++ b/yaehmop/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: lantw44 (at) gmail (dot) com
+# http://codepad.org/XEk6PJYc
+
+pkgname=yaehmop
+pkgver=3.1.0b2
+pkgrel=1
+pkgdesc="Yet Another extended Huckel Molecular Orbital Package"
+arch=('x86_64' 'i686')
+url="http://yaehmop.sourceforge.net/"
+license=('GPL')
+depends=('gcc-fortran' 'readline' 'libx11' 'blas' 'lapack')
+
+source=('http://downloads.sourceforge.net/project/yaehmop/yaehmop-beta/3.1.0b2/bind.3.1.0b2.tgz'
+ 'http://downloads.sourceforge.net/project/yaehmop/yaehmop-beta/3.1.0b2/viewkel.3.1.0b.tgz'
+ 'http://downloads.sourceforge.net/project/yaehmop/yaehmop-beta/3.1.0b2/dense_eval.3.1.0b.tgz'
+ '0001-Fix-build-problems.patch')
+
+md5sums=('5a717a1f9c5dbe6cf36de15cb3c5b6ef'
+ 'd629bface0f610f7a4a1b3d0305872ca'
+ 'aec78fae520950777b7738cf42626d99'
+ '4290dcf6a1ddb040c38dbb54d8698c5b')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ mv ../viewkel ./
+ mv ../dense_eval viewkel/
+ mkdir bin
+ rm -f tightbind/bind
+ rm -f tightbind/utils/fit_coop
+ rm -f tightbind/utils/fit_coop.o
+ rm -f tightbind/utils/fit_dos
+ rm -f tightbind/utils/fit_dos.o
+ rm -f tightbind/utils/genutil.o
+ patch -p1 < ../../0001-Fix-build-problems.patch
+ cd tightbind
+ make -f makefile.linux install
+ cd ../viewkel
+ make -f makefile.linux
+ make -f makefile.linux install
+ make liborbitals.a
+ make libsolids.a
+ make libgenutils.a
+ cd dense_eval
+ make
+ cp -p dense_eval ../../bin
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/${pkgname}/viewkel"
+ cp -rp "${srcdir}/${pkgname}/bin" "${pkgdir}/usr/"
+ install -m 644 "${srcdir}/${pkgname}/viewkel/new_atomic_parms.dat" \
+ "${pkgdir}/usr/share/${pkgname}/viewkel"
+}